An error occurred while installing pg (0.20.0), and Bundler cannot continue. Make sure that `gem install pg -v ‘0.20.0’ –source ‘https://rubygems.org/’` succeeds before bundling.

プログラミング

こんにちは。たなかです。
 
先日からRails tutorialやっています。
またしてもCloud9で環境整えている時にエラーに遭遇したので備忘です。内容は以下の通り。

症状

bundle install時に以下のエラー

An error occurred while installing pg (0.20.0), and Bundler cannot continue.
Make sure that `gem install pg -v '0.20.0' --source 'https://rubygems.org/'` succeeds before bundling.

pgとかいうgemが上手く入っていないようです。

解決方法

 以下のコマンドでpgを実行
$sudo yum -y install postgresql-devel

まとめ

プログラミング

 

結果だけ見ればsudoつけてpg叩きつけるだけって感じでした。
なんか上手くインストールできなかったんですかね。

 

初学者だとsudoって何…?ってなって右往左往しそうだなって思いました。
短いですが今回はここまで。

参考サイト

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です